Moodle 3.4 or later requires at least PHP 7.0.0 (currently using version 5.5.37-1+deprecated+dontuse+deb.sury.org~precise+1). Some servers may have multiple PHP versions installed, are you using the correct executable?